Database load issues
Incident Report for Codecov
Resolved
Database is back and functional. We will continue to monitor, but things look "200 Ok".
Posted over 2 years ago. Feb 15, 2017 - 18:11 UTC
Update
Looks like the new database was not promoted properly #fail
We are spinning up a new one and migrating again.
Posted over 2 years ago. Feb 15, 2017 - 17:28 UTC
Identified
Awaiting feedback from @heroku support on our database being in a read-only state.
Given the read-only state of the database: functionality is restricted to read-only.
Posted over 2 years ago. Feb 15, 2017 - 17:20 UTC
Update
Our database is upgraded, but in a read-only state. Working with Heroku staff to resolve.
Posted over 2 years ago. Feb 15, 2017 - 16:42 UTC
Update
We are migrating data to a larger database instance, which we hope will resolve this issue. Again sorry for the issue and we appreciate your patience.

This happened unexpectedly and we continue to review what was the first event that cased the database to fail.
Posted over 2 years ago. Feb 15, 2017 - 14:37 UTC
Investigating
Our database is having issues serving requests suddenly. Still working hard to resolve. Thank you
Posted over 2 years ago. Feb 15, 2017 - 14:20 UTC
Update
Database issues continue. We are working hard to resolve. Thank you for your patience.
Posted over 2 years ago. Feb 15, 2017 - 12:33 UTC
Update
We identified the issue to be long running queries during refreshing. We have disabled this functionality at the moment as we look into the issue.

Refreshing your repositories/teams will be disabled. Please navigate directly to repositories or teams which bypasses the refreshing agent.
Posted over 2 years ago. Feb 15, 2017 - 11:42 UTC
Identified
After investigating the issue more, it appears to be long running queries on the database. Working to resolve these issues.
Posted over 2 years ago. Feb 15, 2017 - 11:34 UTC
Investigating
We are seeing an large amount of connections with GitHub timing out.
Posted over 2 years ago. Feb 15, 2017 - 11:10 UTC