Timeouts with Github API
Incident Report for Codecov
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 18:09 UTC
Monitoring
We mitigated this issue last night by increasing the timeout limit when communicating with the GitHub API. While we are no longer seeing this issue, we do not consider it resolved since we have not yet identified the cause of the timeouts.
Posted Sep 10, 2020 - 13:40 UTC
Update
We are continuing to investigate this issue.
Posted Sep 09, 2020 - 20:01 UTC
Investigating
We are experiencing intermittent timeouts in communication with the Github API. This will affect all Github customers.

You may see Github Status checks as an error / hung reporting.
Posted Sep 09, 2020 - 19:21 UTC
This incident affected: GitHub.