Longer than normal processing times
Incident Report for Codecov
Resolved
This incident has been resolved. Longer than normal queue times were the combination of an increased processing backlog due to GitHub's incident on 7/22/2019 and a bug in a third party service that resulted in improper scaling of our processing infrastructure. Future work will entail taking more measures to ensure that our infrastructure can properly respond in the event of a GitHub service outage.
Posted about 1 month ago. Jul 23, 2019 - 11:50 UTC
Monitoring
A fix has been implemented and our processing queues have returned to nominal volume. Thank you for your patience today!
Posted about 1 month ago. Jul 23, 2019 - 01:53 UTC
Investigating
We're experiencing longer than usual processing times due to an increase in upload latency we're currently investigating
Posted about 1 month ago. Jul 22, 2019 - 23:29 UTC
This incident affected: Backend.