Incidents with reports not processing
Incident Report for Codecov
Resolved
Hi all, we are very grateful for your patience. We pushed a new patch and have confidence that Codecov should be working for all users, except in very rare edge cases that we are still looking into. If you are still having hung processing / reports, please email us at support@codecov.io Thanks!
Posted 2 months ago. Sep 14, 2018 - 16:18 UTC
Identified
We are working through a notification backlog. Thank you for your patience.
Posted 2 months ago. Sep 14, 2018 - 15:11 UTC
Investigating
Update on reports not processing from yesterday-- the issue continues for some users, and our patch from yesterday has not worked to address all cases. We are investigating in more detail possible root causes and solutions.

Please continue to send in any errors you are experiencing to support@codecov.io --> your additional data is helping us get to the bottom of the issue.
Posted 2 months ago. Sep 12, 2018 - 20:53 UTC
Monitoring
Starting a few days ago, about 1 in 100 reports dropped and did not process. It would have looked like the report was stuck or hung in processing.

We have patched this bug and are monitoring the results. If you experienced this error, we recommend re-running your CI pipeline on this pull requests with hung processing.

Please reach out with any additional questions or issues resulting from this: support@codecov.io
Posted 2 months ago. Sep 11, 2018 - 21:35 UTC
This incident affected: Backend.