High SQL Demand
Incident Report for Codecov
Resolved
Thank you for your patience. We are back at full throttle working through the remaining jobs.
Posted almost 2 years ago. May 11, 2017 - 22:03 UTC
Identified
Yippie! We found the bad query. Patching now.
Posted almost 2 years ago. May 11, 2017 - 21:47 UTC
Update
We apologize for the queue of unprocessed reports. We are focused on frontend performance and will work through report processing as best we can.

Due to recent demand we need to scale up the database resources. We have started this process already :)
Posted almost 2 years ago. May 11, 2017 - 21:16 UTC
Update
We are scaling down report processing workers to mitigate web traffic. Expect delays in report process.
Thank you for your patience.
Posted almost 2 years ago. May 11, 2017 - 21:03 UTC
Monitoring
Database is recovering. The reason for the issue is still unknown.
Posted almost 2 years ago. May 11, 2017 - 20:47 UTC
Investigating
We are seeing query delays that is impacting system performance.
Posted almost 2 years ago. May 11, 2017 - 20:34 UTC