Downtime
Incident Report for Codecov
Resolved
After monitoring we are confident this issue is resolved. The offending node pools have been decommissioned and current uptime appears to be in alignment with our usual performance.

The decommissioned node pools still exist, and will be investigated to attempt to determine a root cause.
Posted Feb 21, 2020 - 18:23 UTC
Monitoring
We will be monitoring this issue over the next 72 hours and working to determine root cause.
Posted Feb 16, 2020 - 17:02 UTC
Identified
We identified an issue that our node pools for our web and worker pods were -- for current lack of a better word -- corrupted. We're investigating the source of the corruption and hope to have a more complete understanding soon.

However we have moved web and worker deployments to new node pools that appear to be functioning normally. Codecov should be fully operational but we will keep status at monitoring while we continue to investigate root cause and track metrics on new node pools
Posted Feb 16, 2020 - 17:01 UTC
Investigating
We are investigating 500 errors on https://codecov.io. We are working to resolve this issue as quickly as possible.
Posted Feb 16, 2020 - 14:04 UTC
This incident affected: Codecov Frontend and Codecov Backend.