Unable to upload reports or complete sync with Github/Gitlab/Bitbucket
Incident Report for Codecov
Resolved
We are confirming that our backlogs and sync jobs have returned to normal service. Apologies for the issue.
Posted Jul 21, 2020 - 19:07 UTC
Monitoring
A fix has been implemented and the upload backlog / delays have been remediated. Our uploads service has returned to normal.

Some sync'ing issues are still affecting users and we have filed further investigation. As an interim workaround for syncing, you can navigate directly to an org or a repo in question via URL www.codecov.io/[gh...gl...bb]/[org_name]/[repo_name].
Posted Jul 21, 2020 - 07:17 UTC
Identified
We have identified the breaking change and have rolled back our worker to remove backlogged / timed out uploads. The queue should be returned to 0 within the next 1-3 hours. We will update again once our queue is at 0.
Posted Jul 21, 2020 - 06:48 UTC
Investigating
We are investigating two lines of issues: about 8% of uploads are timing out or not completing, and the majority of `sync` repos or organizations is not working within our application.

We will update as soon as possible.
Posted Jul 21, 2020 - 05:01 UTC
This incident affected: Frontend and Backend.