Error fetching reports
Incident Report for Codecov
Resolved
We have now resolved issue for both go-forward coverage reports and retroactively for coverage reports during the affected time: 2020-10-06 19:00:45.400 UTC to 2020-10-07 13:27.000 UTC

There are a very small minority of coverage reports that may still need manual help. If you have a commit from the date range above and are seeing the error `Unable to find report content in the storage archive`, please feel free to reach out to us at https://codecov.io/support
Posted Oct 08, 2020 - 15:18 UTC
Update
We have identified the source of this issue. Due to a configuration discrepancy, processed coverage reports for commits were placed in the wrong storage location from 2020-10-06 19:00:45.400 UTC to 2020-10-07 13:27.000 UTC.

The issue has been fixed and any reports that begin uploading now and in future (after 2020-10-07 13:27.000 UTC) should work properly. Additionally, we are investigating approaches to restore the misplaced coverage reports.

This misplaced storage led to an issue where notifications, report processing, and status updates worked properly, but the processed results where unreachable by the codecov.io web ui. For the end users this problem manifested as an "Unable to fetch report from storage archive" when viewing single commits or pull requests and comparisons between commits.
Posted Oct 07, 2020 - 15:15 UTC
Identified
We have identified the cause of the errors and are deploying a fix.
Posted Oct 07, 2020 - 13:28 UTC
Investigating
When trying to access your reports on Codecov, you may see the error `Unable to find report content in the storage archive.` We are aware of this issue and are investigating.
Posted Oct 06, 2020 - 19:00 UTC
This incident affected: Codecov Frontend.