Bitbucket API connection is down
Incident Report for Codecov
Resolved
After 12 hours of review, the issue appears to be fully resolved. If you have additional issues with the bitbucket api please let us know by contacting support@codecov.io
Posted 3 months ago. Jun 28, 2019 - 13:47 UTC
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jun 28, 2019 - 13:46 UTC
Monitoring
A fix for bitbucket API issues has been deployed to production. We'll be actively monitoring the issue to ensure the issue is fully resolved.
Posted 3 months ago. Jun 28, 2019 - 01:45 UTC
Identified
We have identified deprecated areas of Bitbucket API and pushed a fix for most key features for Bitbucket + Codecov Integration. If you need to Oauth via Bitbucket into Codecov, you may still experience intermittent outages and we are working to find a consistent fix for Bitbucket Oauth.
Posted 3 months ago. Jun 28, 2019 - 00:32 UTC
Investigating
For all users of Bitbucket with Codecov, we are experiencing outages on Codecov with deprecated pieces of the Bitbucket API v1.
Posted 3 months ago. Jun 27, 2019 - 20:32 UTC
This incident affected: Backend.