Performance issues on upload
Incident Report for Codecov
Resolved
The core issue has been resolved. The problem was due to a small change we made in our presigned PUT header signing process that led to the url being rejected in certain edge cases reports were inadvertently uploaded to a backup cloud storage solution that did not accept the modified header.

This issue has been rectified by ensuring the header change won't result in a rejected PUT when falling back to backup cloud storage.
Posted 13 days ago. Oct 03, 2019 - 23:28 UTC
Monitoring
A fix has been implemented and we are monitoring.
Posted 13 days ago. Oct 03, 2019 - 21:55 UTC
Investigating
We are investigating performance issues in uploading / backend worker.
Posted 13 days ago. Oct 03, 2019 - 21:04 UTC
This incident affected: Backend.